[INVESTIGATING] neutron not scanning music correctly

Report bugs and unexpected behavior here.
dmitrykos
Site Admin
Posts: 1847
Joined: Mon Apr 25, 2011 6:15 pm

Re: [INVESTIGATING] neutron not scanning music correctly

Post by dmitrykos » Tue Feb 12, 2013 5:15 pm

rmalone wrote:I'm having a similar problem just installed today I had only about 100 songs. I have a new thread right above this. I went from 9 albums to 2 and now 0. It looks like its scanning but for less time and well nothing ends up loading up?
Would you please e-mail one such track? If it is AIFF then the bug is fixed, if not AIFF it would be great to have one music file: neutronmp@gmail.com, or I can provide FTP access for uploading in case file is big. Difficult to say what is the problem without the file, unfortunately.

dmitrykos
Site Admin
Posts: 1847
Joined: Mon Apr 25, 2011 6:15 pm

Re: [INVESTIGATING] neutron not scanning music correctly

Post by dmitrykos » Tue Feb 12, 2013 5:18 pm

mkosma wrote:I am experiencing a similar problem. In my case, I have some albums that show up under ALBUM browse but not ARTIST. For example, I can find Beck's Modern Guilt and The Information albums under Songs, and under Albums, but there is no entry for Beck under Artists.
Would you please clarify: you see Beck entry in Artists but once you tap on Beck entry there are no albums listed for this artist? May I have that M4A file to neutronmp@gmail.com for debugging the Neutron scanning core?

htom
Posts: 30
Joined: Wed Oct 26, 2011 7:45 pm

Re: [INVESTIGATING] neutron not scanning music correctly

Post by htom » Tue Feb 12, 2013 7:41 pm

dmitrykos wrote:htom, what about tags of your WAVs. The problem with WAV is that this format is not well designed for metadata and most probably it is just missing necessary information? The best way to overcome this problem is to re-encode it to FLAC may be? Just with the same format 24/96 and correct metadata of converted files. FLAC is lossless and thus there won't be any change in quality. Another approach to convert to AIFF which is similar to WAV but may contain ID3 tags and can be easily tagged with iTunes app.
This seems to have resolved the problem, but it raises another issue. I find that the track titles for this album seem to include the track number; that is, while most every other album will display track title, and the top will read which track it is (say, [4/12]), this particular album will display as "01 She Found Now" and in examining the tags and files I can find no reason for the differentiation. Not a real problem but I did find it odd.

Another possible issue is the nature of gapless playback. You've noted that the feature is mostly for MP3 format, but I find that WMA files also play back with a gap, while they do not when using Windows Media Player; in fact, most MP3 files play back on WMP without a gap. Examining WMA files with a sound editor finds very short silences at the front and back of most files, so it would seem that some sort of metadata solution is used to play back gaplessly, again like I've heard is usually done for MP3 files.

However, the one MP3 album I do have on my phone does not play back gaplessly with your feature enabled (or disabled, for that matter), while the same tracks play back gaplessly with WMP.

dmitrykos
Site Admin
Posts: 1847
Joined: Mon Apr 25, 2011 6:15 pm

Re: [INVESTIGATING] neutron not scanning music correctly

Post by dmitrykos » Thu Feb 14, 2013 6:17 pm

> the one MP3 album I do have on my phone does not play back gaplessly with your feature enabled

Could you please e-mail to me 2 of your WMA files to neutronmp@gmail.com for experiments? I will try to analyze metadata and find the pointer to audio data.

> this particular album will display as "01 She Found Now"

And this one if possible :)

Unfortunately without problematic files it is practically impossible to guess the guilty place in code (if problem is in Neutron logic) because it is already very complicated.

I can also provide access to FTP server for direct uploading if files are too big for e-mailing.

warrenmr
Posts: 23
Joined: Sun Feb 10, 2013 6:14 pm

Re: [INVESTIGATING] neutron not scanning music correctly

Post by warrenmr » Fri Feb 15, 2013 3:28 pm

I am also having problems with Neutron recognizing all songs on the sdcard of my Z10.

When the songs were in a directory called /music, only approximately 10 percent were recognized (all with folders early in the alphabet). When I deleted all the recognized folders, no songs were recognized.

When I copy the remaining songs to the same card, but in a folder called /tunes, different songs are recognized (but not the same one side as before since they have been deleted).

mkosma
Posts: 6
Joined: Sun Aug 19, 2012 1:02 am

Re: [INVESTIGATING] neutron not scanning music correctly

Post by mkosma » Mon Feb 18, 2013 8:38 pm

Hi Dmitry, I'm emailing you a copy of one of the Beck songs. To clarify, these were ripped from original CDs in FLAC, then transcoded to Apple Lossless (m4a).

And, to clarify, I have several Beck albums on my phone, and ALL of them show up under Albums, but Beck (artist) does not show up under Artists, nor any of his albums.

File is on the way, via email.

dmitrykos
Site Admin
Posts: 1847
Joined: Mon Apr 25, 2011 6:15 pm

Re: [INVESTIGATING] neutron not scanning music correctly

Post by dmitrykos » Mon Feb 18, 2013 8:50 pm

Hi! :) Thank you very much. Got the file!

dmitrykos
Site Admin
Posts: 1847
Joined: Mon Apr 25, 2011 6:15 pm

Re: [INVESTIGATING] neutron not scanning music correctly

Post by dmitrykos » Mon Feb 18, 2013 8:50 pm

Hi! :) Thank you very much. Got the file!

htom
Posts: 30
Joined: Wed Oct 26, 2011 7:45 pm

Re: [INVESTIGATING] neutron not scanning music correctly

Post by htom » Wed Feb 20, 2013 12:52 am

dmitrykos wrote:> the one MP3 album I do have on my phone does not play back gaplessly with your feature enabled

Could you please e-mail to me 2 of your WMA files to neutronmp@gmail.com for experiments? I will try to analyze metadata and find the pointer to audio data.
The files have been sent in both MP3 and WMA format, as both behave in the same manner for each player; that is, gaplessly for WMP and with a gap for Neutron.
dmitrykos wrote:> this particular album will display as "01 She Found Now"

And this one if possible :)

Unfortunately without problematic files it is practically impossible to guess the guilty place in code (if problem is in Neutron logic) because it is already very complicated.

I can also provide access to FTP server for direct uploading if files are too big for e-mailing.
It turned out I was able to eliminate the problem simply by deleting the leading '0' in each file; this album only had nine tracks anyway so there was little point in having it there. This might be a clue?

Post Reply

Who is online

Users browsing this forum: Bing [Bot] and 1 guest