Bluetooth issue

Report bugs and unexpected behavior here.
Post Reply
Smabbage
Posts: 10
Joined: Tue Mar 06, 2012 2:06 pm

Bluetooth issue

Post by Smabbage » Mon Apr 30, 2012 2:18 pm

I don't know if this is a issue with Neutron Player or if it is a Bluetooth issue or if it's a issue with the head unit in my car but when playing music over Bluetooth, the song title info is a track behind. It will update to the current track info if I pause the track and restart but it will not show the next track info until it moves to the third track which puts the track info a track behind again. I hope my explanation of what is happening isn't too confusing. Any help would be appreciated.

dmitrykos
Site Admin
Posts: 1847
Joined: Mon Apr 25, 2011 6:15 pm

Re: Bluetooth issue

Post by dmitrykos » Mon Apr 30, 2012 3:44 pm

Thank you very much for the report. I will try to reproduce the problem and fix it asap.

dmitrykos
Site Admin
Posts: 1847
Joined: Mon Apr 25, 2011 6:15 pm

Re: Bluetooth issue

Post by dmitrykos » Mon Apr 30, 2012 4:42 pm

I tried to reproduce with screen off and on but in all cases BT device was updating its display with tags on track changes. Could it be the case that your Android device delays AVRCP messages for some reason? Have you tried rebooting the device?

Smabbage
Posts: 10
Joined: Tue Mar 06, 2012 2:06 pm

Re: Bluetooth issue

Post by Smabbage » Tue May 01, 2012 2:21 am

Thanks for looking into this. Given all the things it could be from the ROM to the head unit in the car to who knows what, I may never figure it out. At least you've eliminated the player as a possibility.

Liveinthemoment
Posts: 209
Joined: Fri Feb 24, 2012 2:40 am

Re: Bluetooth issue

Post by Liveinthemoment » Tue May 01, 2012 3:28 am

I just tried it and it works fine for me. Will report back if i find anything out though.

I am testing bluetooth with my portable Bose Soundlink Mobile Wireless Speaker with Neutron.

Smabbage
Posts: 10
Joined: Tue Mar 06, 2012 2:06 pm

Re: Bluetooth issue

Post by Smabbage » Tue May 01, 2012 8:17 pm

I'm beginning to think that my Kia UVO system doesn't refresh the track information unless the music is paused and restarted. I see the same behavior no matter which BT enabled music player I use. Ah well. Perhaps a firmware update from Kia will fix the problem...

dmitrykos
Site Admin
Posts: 1847
Joined: Mon Apr 25, 2011 6:15 pm

Re: Bluetooth issue

Post by dmitrykos » Wed May 02, 2012 10:14 am

Ok, thanks for the update on it! Testing with stock player is a good method to check whether something goes wrong in the OS or not.

Post Reply

Who is online

Users browsing this forum: No registered users and 27 guests