[Z10] Song ratings not showing up

Report bugs and unexpected behavior here.
Post Reply
Spoony
Posts: 6
Joined: Sat Aug 03, 2013 5:30 pm

[Z10] Song ratings not showing up

Post by Spoony » Sat Aug 03, 2013 5:45 pm

Would like to start by stating I love this piece of software, have been running this on my Z10 for a number of weeks and the combination of my Z10 and Neutron has made my iPod completely obsolete - sound quality, customization and overall quality are fantastic. However...

I've been trying to figure one problem out that has been driving me nuts. All my songs show up with no ratings (0 stars) in Neutron, as I do a fair amount of my listening and playlist generation using ratings this has become a very bothersome problem.

The files themselves have ratings on the laptop they are synced from and I've verified the files on the device also have ratings via their properties but they show up in Neutron with no stars.

I didn't find any hits for this on the forum so I'm assuming I've missed some obvious setting somewhere.

dmitrykos
Site Admin
Posts: 1847
Joined: Mon Apr 25, 2011 6:15 pm

Re: [Z10] Song ratings not showing up

Post by dmitrykos » Tue Aug 06, 2013 10:31 am

Unfortunately reading rating from tags is not yet implemented and it is in to-do list. But, Neutron's policy is to open user files in read-only mode, to avoid any single modification to the file system, so in such situation if you rate some track in Neutron it can't be synchronized with file tags.

Chris
Posts: 10
Joined: Sun Dec 29, 2013 1:37 pm

Re: [Z10] Song ratings not showing up

Post by Chris » Thu Jan 09, 2014 7:55 am

I'm happy to hear that "reading the rating from tags" is on the to-do list. This would be a much appreciated feature for me.

I would also prefer to be able to rate the songs within Neutron and have those ratings written back to the files. This could even be a separate export feature in the menu. Rating only within Neutron without making this visible for other programs (e.g on PC) is useless to me (no harm ment - only beeing honest - I really don't use it).

For others who want to rate their music while on the way - I found a workaround...
As a long time user of MediaMonkey on the PC to manage my music collection, I recently learned that there is a version for android that can sync between your android device and your PC (which includes metadata like ratings).

Now I rate my songs using MediaMonkey and those ratings get synced back to the PC after getting home.
So now I need Neutron to pick up this information ;)

thanks
chris

Liveinthemoment
Posts: 209
Joined: Fri Feb 24, 2012 2:40 am

Re: [Z10] Song ratings not showing up

Post by Liveinthemoment » Fri Jan 10, 2014 9:14 am

I really disagree guys.

Tagging in Android is a disaster. I have tested all the tagging apps available - if you write to tags a few times they will break altogether (I wrote a post about this here a year ago).

Don't even go there - read only mode keeps our files safe. +1 to not change this feature.

Chris
Posts: 10
Joined: Sun Dec 29, 2013 1:37 pm

Re: [Z10] Song ratings not showing up

Post by Chris » Fri Jan 10, 2014 9:40 am

Hi Liveinthemoment

I value your opinion and thanks for sharing your practical experience.
Have you also tried MediaMonkeyAndroid (which still is Beta) and if yes, what problems did you find?

But I have to disagree too ;-)

Everyone serious about his music collection needs a tool and way to tag and rate the songs.
I have been doing this for years now and have not encountered any problems.
I don't see a reason why tagging on an Android device should be fundamental more problemtic than tagging it on e.g a Windows system. The risk is not depending on the OS but on how well the functionality is implemented.

But I think we have a consensus too :-)
The main point (the feature that is really missing) is that Neutron should be able to READ the ratings.
Please don't let my comment about the possiblity to "export the internal tagging" put you off - it was an optional idea.

Let's support the idea to READ the ratings
and everyone should be happy about that.

Thanks
Chris

fonetval
Posts: 2
Joined: Tue May 16, 2017 9:04 pm

Re: [Z10] Song ratings not showing up

Post by fonetval » Fri May 19, 2017 10:52 am

Hi everyone,

+1 for reading (at least) song's rating !

I know is a quite old topic, but in the actual version of Neutron... Still not available :-(

Of course, it's not only "reading" that is important, it's being able to use it in filter/playlist build of course !

So, even a little utility to "import from MP3 to SQLite Neutron database" will be valuable : I do not develop anymore today, but I know that it does not represent an important difficulty to make such a program.

Com'on guys, I beg you please :roll: !

GraefinZahl
Posts: 3
Joined: Fri May 26, 2017 5:27 am

Re: [Z10] Song ratings not showing up

Post by GraefinZahl » Fri May 26, 2017 6:45 am

+1 for reading song ratings! :)

fabianofsouza
Posts: 1
Joined: Thu Jun 07, 2018 11:04 pm

Re: [Z10] Song ratings not showing up

Post by fabianofsouza » Thu Jun 07, 2018 11:10 pm

+1 for reading and writing tag's ratings (at list in iPhone vers)
Let continuity bless us all!

Chris
Posts: 10
Joined: Sun Dec 29, 2013 1:37 pm

Re: [Z10] Song ratings not showing up

Post by Chris » Sat May 04, 2019 7:46 pm

I still use Neutron as my main player and I still miss that it isn't reading the ratings.

I use MediaMonkey for rating and syncing to my mobile phone. So picking up those ratings by Neutron would be great.
Still hope this feature will come some times.

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests