[WORKAROUND] Album art not showing up

Report bugs and unexpected behavior here.

[WORKAROUND] Album art not showing up

Postby Razguul » Mon May 28, 2012 7:15 pm

When I browse my albums, I can see album art but when I open such an album and click on a song to play the main screen just shows the word Neutron and the Neutron logo and controls at the bottom. Why isn't the album art showing?
Razguul
 
Posts: 6
Joined: Sun May 27, 2012 9:45 pm

Re: Album art not showing up

Postby dmitrykos » Tue May 29, 2012 8:09 am

Hi! :)

It would be great to have more details:
- are album music files placed in separate (album) directory?
- do you have album art image file in that directory, or images are inside music files metadata?
dmitrykos
Site Admin
 
Posts: 1778
Joined: Mon Apr 25, 2011 6:15 pm

Re: Album art not showing up

Postby Razguul » Tue May 29, 2012 3:09 pm

Found the problem. Your player is the only one I've EVER used that doesn't adhere to the Android established music DB (it was created for a reason). Why on earth you do notwant to support it is your business I guess. You should have at least supported it like everyone else IMO as other programs also use it (coming from a retired WIndows/UNIX developer).
Razguul
 
Posts: 6
Joined: Sun May 27, 2012 9:45 pm

Re: Album art not showing up

Postby Liveinthemoment » Wed May 30, 2012 3:00 am

My 2 cents.......but first I am guessing your issue might be

(1) you need to rescan your music after making changes ? (Neutron doesn't update automatically with that though new albums have shown for me I believe)

(2) related to tags - what version are your tags and what software have you checked them with ?

- Mine for example are:
a) 90% Vorbis (Flac)
b) 10% - ID3V2.4 (though also in addition tagged with ID3v1 and most also with APE)
- I use cover.jpg with each album with its own directory eg music\artist\album\songs mostly but have a few where it is in tags (variety of artists in 1 directory in that case).

Using mp3tag you can confirm if your tags are correct - my understanding is this - if your tags are correct in this program it would be exceedingly unlikely for them not to work in Neutron.
http://www.mp3tag.de/en/download.html


From the FAQ page - http://neutronmp.com/faq.html
====================================================================================================
Q: I do not see album art, does Neutron support it?

A: Yes. Being not usual Android application Neutron does not use Android internal media database and thus will not pick album art from it. Neutron builds own media database and searches for album art in: folders where music files are located, or tags of music files. So, to have album art visible make sure that either one of these 2 conditions is met. Using one of the free Android apps for album art downloading/extraction would really help to sort out this.
====================================================================================================

(1) about your Album Art not showing
We cannot help you if you do not tell us how your album art is arranged
- a JPEG in an Album's directory ?
- tags with all songs in one directory ?
- do none show or only some ?

(2) About using its own database - my vote is +1 for Dmitry NOT to use the default database
- easy to use, simply choose directory and add
- I have 500 cds and the default (not Neutron) takes around 40 mins to do a complete rebuild versus 1 minute with Neutron, also on ICS the default rebuilding crashes a lot.
- Other players eg TTPod have their own database

I keep all my music in the default directory so I can use these programs - I have 500 CDs all with correct tagging and album art working in Neutron (only 1 album with corrupted tags - should redo that 1)

Album Art Grabber:
https://play.google.com/store/apps/deta ... m.citc.aag

Tagging software

1) Itag Pro
https://play.google.com/store/apps/deta ... fe.itagpro

2) Pimpmymusic
https://play.google.com/store/apps/deta ... pickup.pmm
Liveinthemoment
 
Posts: 209
Joined: Fri Feb 24, 2012 2:40 am

Re: Album art not showing up

Postby dmitrykos » Thu May 31, 2012 7:51 am

Hi Scott! :) Thank you for a lot of valuable work on album art details, I made this thread sticky in Support section. I hope it helps users.
dmitrykos
Site Admin
 
Posts: 1778
Joined: Mon Apr 25, 2011 6:15 pm

Re: Album art not showing up

Postby dmitrykos » Thu May 31, 2012 7:59 am

Razguul wrote:Found the problem. Your player is the only one I've EVER used that doesn't adhere to the Android established music DB (it was created for a reason).


The reason is simple: Android OS has slow system API and getting album art from Android DB involves going to Java, construction of lookup query, internal lookup in the system media database. From the perspective of speed of execution of this stuff it is a lot of time. Only since 1.58 Neutron's UI got fully asynchronous lookup/loading/resizing of album art images and now scrolling Albums section of Playlist screen is much more smoother. So it is already possible to do this costly Android lookup but it still takes much more CPU/memory than if it is done solely inside Neutron's DB.

Another reason to stick to only Neutron DB is possibility to migrate to other platforms in the future. You just move /NeutronMP folder to another device along with music database and have it working out of the box. That is why I am trying to avoid dependencies on specific platform as much as possible.
dmitrykos
Site Admin
 
Posts: 1778
Joined: Mon Apr 25, 2011 6:15 pm

Re: Album art not showing up

Postby sherrington » Wed Jul 18, 2012 7:16 pm

I found that you also have to resize the albumn art for it to show. I resized mine to 240 x 240 and changed the tags. All my art works perfectly now. You do need to rescan all the files after you have done it :D :D :D
sherrington
 
Posts: 7
Joined: Sun Jul 15, 2012 3:50 pm

Re: Album art not showing up

Postby dmitrykos » Thu Jul 19, 2012 7:52 am

Could you please tell me what was the original size of images? I will check Neutron's code then, may be there is bug in such situation.
dmitrykos
Site Admin
 
Posts: 1778
Joined: Mon Apr 25, 2011 6:15 pm

Re: Album art not showing up

Postby sherrington » Thu Jul 19, 2012 5:56 pm

They were various sizes, mostly a lot larger than 500 x 500 pixels. After changing the very large files in the tags of some of my music, the art now shows perfectly. I also found that even if a file existed in the folder it didn't necessarily showed it. Very happy with the quality of the sound. I think you need to work a bit now on the UI. Keep up the good work. :D
sherrington
 
Posts: 7
Joined: Sun Jul 15, 2012 3:50 pm

Re: Album art not showing up

Postby Liveinthemoment » Fri Jul 20, 2012 12:08 am

My images are mostly 500 by 500 but many are double that and I have no issues at all with any.

500 of them.
Liveinthemoment
 
Posts: 209
Joined: Fri Feb 24, 2012 2:40 am

Next

Return to Support



Who is online

Users browsing this forum: No registered users and 12 guests